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Copyright © 2006-2012 Jean Bréfort

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License
(GFDL), Version 1.3 or any later version published by the Free Software Foundation with no Invariant Sections, no Front-Cover
Texts, and no Back-Cover Texts. You can find a copy of the GFDL at this link or in the file COPYING-DOCS distributed with
this manual.

This manual is part of a collection of GNOME manuals distributed under the GFDL. If you want to distribute this manual
separately from the collection, you can do so by adding a copy of the license to the manual, as described in section 6 of the
license.

Many of the names used by companies to distinguish their products and services are claimed as trademarks. Where those
names appear in any GNOME documentation, and the members of the GNOME Documentation Project are made aware of those
trademarks, then the names are in capital letters or initial capital letters.

DOCUMENT AND MODIFIED VERSIONS OF THE DOCUMENT ARE PROVIDED UNDER THE TERMS OF THE GNU
FREE DOCUMENTATION LICENSE WITH THE FURTHER UNDERSTANDING THAT:

1. DOCUMENT IS PROVIDED ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE DOCUMENT OR MODIFIED
VERSION OF THE DOCUMENT IS FREE OF DEFECTS MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE
OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY, ACCURACY, AND PERFORMANCE OF THE
DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT IS WITH YOU. SHOULD ANY DOCUMENT OR
MODIFIED VERSION PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL WRITER, AUTHOR OR
ANY CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS
DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY DOC-
UMENT OR MODIFIED VERSION OF THE DOCUMENT IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS
DISCLAIMER; AND

2. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER IN TORT (INCLUDING NEGLI-
GENCE), CONTRACT, OR OTHERWISE, SHALL THE AUTHOR, INITIAL WRITER, ANY CONTRIBUTOR, OR
ANY DISTRIBUTOR OF THE DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT, OR ANY SUPPLIER
OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDEN-
TAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAM-
AGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY
AND ALL OTHER DAMAGES OR LOSSES ARISING OUT OF OR RELATING TO USE OF THE DOCUMENT AND
MODIFIED VERSIONS OF THE DOCUMENT, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE
POSSIBILITY OF SUCH DAMAGES.

Feedback

To report a bug or make a suggestion regarding the GChem3d application or this manual, go to the GChem3d home page.

ghelp:fdl
http://savannah.nongnu.org/projects/gchemutils
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Abstract

GChem3d allows you to display molecular structures.
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Introduction

The GChem3d application is a simple molecular structures visualizer.
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Chapter 1

Getting started

1.1 To Start GChem3d

You can start GChem3d in the following ways:

Applications list Choose “Molecules Viewer”. It might be listed either in the Education or Science category.

Command line Type gchem3d, then press Return.

1.2 When You Start GChem3d

When you start GChem3d, the following window is displayed:

Figure 1.1: GChem3d main window

The GChem3d window contains the following elements:

Menubar The menus on the menubar contain all of the commands you need to work with files in GChem3d.

Display area The display area contains the contents of an opened file if any.
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1.3 To Open a File

To open a file, choose File → Open to display the Open File dialog. Select the file that you want to open, then click OK. The file
is displayed in the GChem3d main window.

GChem3d can open files on a distant server.

GChem3d can open several file formats. Available formats are:

• ChemML files (*.cml)

• MDL MOL files, MDL Structure Data files (*.mol;*.sd;*.sdf)

• PDB files (*.pdb;*.ent)

• XYZ Coordinate Format files (*.xyz)

You can open multiple files in GChem3d. The application displays each file in its own window.

Recently opened file appear in the File+Open recent sub-menu.

A molecule can also be loaded from it’s InChI or a SMILES representation as described in the To Load a Molecule from a String
section.

1.4 To Open Multiple Files from a Command Line

You can run GChem3d from a command line and open a single file or multiple files. To open multiple files from a command line,
type the following command, then press Return:

gchem3d file1 file2 file3



GChem3d manual 3 / 12

Chapter 2

Usage

2.1 To Save the View as an Image

To open a file, choose File → Save as Image... to display the Save as image dialog. Select a file name and, if wanted, a file type
and a size, then click OK. Default image size is 300 pixels wide and 300 pixels high.

Supported types are VRML, Postscript, Encapsulated Postscript, PDF, and all types that GdkPixbuf can export. You’ll find an
exact list in the drop-down file type menu.

If no file type is specified, GChem3d tries to determine the type from the file name. If it does not succeed, the default type
(VRML) will be used.

An appropriate extension will be added to the file name if none is found.

PostScript and PDF files can also be obtained with the Print command.

2.2 To Load a molecule from an InChI or a SMILES

To import a molecule from a string, choose Tools → Import molecule... . A dialog box pops up:

Figure 2.1: The string input dialog box.

You need to input a valid string such as this SMILES:
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Figure 2.2: The string input dialog box with a SMILES inside.

Please note that if you use an InChI as input, you must not skip the “InChI=” prefix.

After activating the Apply button you get:

Figure 2.3: The 3D View.

2.3 To Use the Tools Menu with a molecule.

When a molecule is displayed, several menu items appear in the Tools menu:

Open in GChemPaint Opens the 2D editor GChemPaint with a copy of the molecule. The molecule has been converted to a
2D representation using the OpenBabel library.

With the trans-1,2-dimethylcyclohexane molecule, you get:

ghelp:gchempaint-0.14
http://openbabel.sourceforge.net/
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Figure 2.4: Initial view in GChem3D.

And after conversion in GChemPaint:

Figure 2.5: The molecule in GChemPaint.

Open in GChemCalc Opens the chemical calculator GChemCalc with a copy of the molecule formula and performs the avail-
able calculations. With the same molecule as above, you get:

ghelp:gchemcalc-0.14
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Figure 2.6: The molecule in GChemCalc.

Generate InChI Generates the InChI for the molecule and displays it in a popup window.

Generate InChIKey Generates the InChIKey for the molecule and displays it in a popup window.

Generate SMILES Generates the SMILES for the molecule and displays it in a popup window.

Search in an online database The molecule can be searched for in online databases, either predefined or user defined.

To add custom databases, you need to create an xml file listing them. The file must be named .gchemutils/databases.xml
in you home directory.

Entries inside the file must be inside a databases top node, each entry being a database node with children name, uri, and
class, like for the NIST webbook (which is predefined):

<database>
<name>NIST webbook</name>
<uri>http://webbook.nist.gov/cgi/cbook.cgi?Name=%K&Units=SI"</uri>
<class>molecule</class>

</database>

where %K will be replaced by the InChIKey. Tou use the InChI, the code is %I and for the SMILES, %S.

The class node is for future usages and must contain “molecule”.

2.4 To Print the View

To print a file, choose File → Print....
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GChem3d uses a 300 dpi resolution when printing.

You might want to change the background color before printing.

File → Preview opens a window with a preview of the printed output.

To tune the printed output, chooseFile → Page setup... as explained below.

2.4.1 The page setup dialog.

the first tab of the dialog concerns the paper and margins setup. Headers and footers are not supported in the version of GChem3d

Figure 2.7: The Page Setup tab.

The second tab allows you to choose the scale of the output. With no scaling or scaling at 100%, the output will have the same
size in points as the size in pixels on the screen. If you choose automatic scaling, you can make the output fill the available space
either horizontally, vertically, or both (none of the options is equivalent to no scaling).

Printing to more than one page is not supported in this version of GChem3d
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Figure 2.8: The Print Scale tab.

2.5 To Change the Model Options

GChem3d is able to display a molecule using four model types: the ball and stick model, the compact model, the cylinders
model, and the wireframe model. The first one is the default. Multiple bonds are displayed as such in the ball and stick model.
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Figure 2.9: The Balls and Sticks model.

Figure 2.10: The Spacefill model.
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Figure 2.11: The Cylinders model.

Figure 2.12: The Wireframe model.

To change the mode, choose either View → Balls and sticks, View → Space filling, View → Cylinders, or View → Wireframe.

The model can also be selected from the command line: gchem3d --display3d=cylinders or gchem3d -d cylinders will open
GChem3d with the cylinders model active. The other models are entered as ball&stick, spacefill, and wireframe.

You can also change the orientation. Just click somewhere in the view and drag the mouse until you get the wanted orientation.

2.6 To Change the Background Color

To change the backgound color, choose View → Background color and select the appropriate color in the palette, or choose a
custom color.
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The background color can also be selected from the command line: gchem3d --bgcolor=white or gchem3d -b white will open
GChem3d with a white background in windows. Recognized strings are black (the default), white, and #rrggbb where r, g, and b
are hexadecimal digits.

2.7 To Ask a Question

If you choose Help → Ask a question, your mail agent should pop up with a new message to the Gnome Chemistry Utils mailing
list.

Another way to get some help is to connect on the #gchemutils channel at irc.gimp.net and ask your question there (if you are
not alone on the channel).

2.8 To Find the Gnome Chemistry Utils on the Web.

If you choose Help → Gnome Chemistry Utils on the web, the default web browser should pop up and display the main page for
the Gnome Chemsitry Utils.

The main page is http://gchemutils.nongnu.org and the project page at savannah http://savannah.nongnu.org/projects/gchemutils.

2.9 To Report a Bug

To report a bug, you must use the bug page for the Gnome Chemistry Utils at Savannah. You can access it by choosing Help
→ Report Bugs (hopefully you’ll have only one at once to report).

You can also type the bug report page address directly in the browser. The bug repository is at https://savannah.nongnu.org/-
bugs/?group=gchemutils

mailto:gchemutils-main@nongnu.org
mailto:gchemutils-main@nongnu.org
irc://irc.gimp.net/gchemutils
http://gchemutils.nongnu.org
http://savannah.nongnu.org/projects/gchemutils
https://savannah.nongnu.org/bugs/?group=gchemutils
https://savannah.nongnu.org/bugs/?group=gchemutils
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Chapter 3

License

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as
published by the Free Software Foundation; either version 3 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
more details.

A copy of the GNU General Public License is included as an appendix to the GNOME Users Guide. You may also obtain a copy
of the GNU General Public License from the Free Software Foundation by visiting their Web site or by writing to

Free Software Foundation, Inc.
51 Franklin St - Fifth Floor
Boston, MA 02111-1307
USA

ghelp:gpl
http://www.fsf.org
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